macd三值最佳设置方法最好是多少

在实践中,MACD指标的背离一般出现在强势行情中比较可靠,股价在高价位时,通常只要出现一次背离的形态即可确认位股价即将反转,而股价在低位时,一般要反复出现几次背离后才能确认。因此,MACD指标的顶背离研判的准确性要高于底背离,这点投资者要加以留意。

三、MACD顶背离公式:(注明:不用软件,指标代码会有细微的区别,请勿随意套用)

DIF:=EMA(CLOSE,12)-EMA(CLOSE,26);

MACD:=EMA(DIF,9),COLOR33CCFF;

DEF:2*(DIF-MACD),COLORFFFF00,LINETHICK0;

STICKLINE(DEF>=0 AND DEF>=REF(DEF,1),0,DEF,0,0),COLORRED;

STICKLINE(DEF>=0 AND DEF< REF(DEF,1),0,DEF,0.0,0),COLORRED;

STICKLINE(DEF<0 AND DEF>=REF(DEF,1),0,DEF,0.0,0),COLORCYAN;

STICKLINE(DEF<0 AND DEF< REF(DEF,1),0,DEF,0.0,0),COLORCYAN;

IF(DIF<1000,0,DRAWNULL),COLORBROWN;

K1:=BACKSET(DIF>REF(DIF,1),2);

强DIF:IF(K1,DIF,DRAWNULL),COLORRED;

K2:=BACKSET(DIF<REF(DIF,1),2);

弱DIF:IF(K2,DIF,DRAWNULL),COLORFF8B80;

K3:=BACKSET(MACD>REF(MACD,1),2);

强MACD:IF(K3,MACD,DRAWNULL),COLORLIRED;

K4:=BACKSET(MACD<REF(MACD,1),2);

弱MACD:IF(K4,MACD,DRAWNULL),COLORFF8B80;

底拐:DRAWLINE(DIF>=HHV(DIF,21),DIF,DIF<=LLV(DIF,21),DIF,1),COLORWHITE,POINTDOT;

DRAWICON(强DIF>底拐 AND REF(DIF,1)=REF(底拐,1) AND REF(DIF,2)>REF(DIF,1),0,1);

A1:=BARSLAST(REF(CROSS(DIF,MACD),1));

底背离:=REF(CLOSE,A1+1)>CLOSE AND DIF>REF(DIF,A1+1) AND CROSS(DIF,MACD);

DRAWLINE(A1=0,MACD,底背离,MACD,0),COLORYELLOW,LINETHICK2;

A2:=BARSLAST(REF(CROSS(MACD,DIF),1));

顶背离:=REF(CLOSE,A2+1)<CLOSE AND REF(DIF,A2+1)>DIF AND CROSS(MACD,DIF);

DRAWLINE(A2=0,MACD,顶背离,MACD,0),COLORGREEN,LINETHICK2;

AA1:=IF(DEF>0,1,-1);

AA2:=REF(AA1,1);

AA3:=AA1*AA2;

AA4:=BARSLAST(AA3<0);

AA5:=AA4+1;

面积:SUM(DEF,AA5)/10,COLORGREEN;

声明:本站所有文章、数据仅供参考,投资有风险,选择需谨慎

发表评论

电子邮件地址不会被公开。 必填项已用*标注