通达信指标公式源码日线压力止损止盈支撑位主图指标

通达信指标公式源码日线压力止损止盈支撑位主图指标

通达信指标公式源码

CC:=IF(CURRBARSCOUNT<18,CONST(REF(C,1)),DRAWNULL);

止赢:=1.05*CC,COLOR8000FF;

止损:=0.97*CC,COLORLIBLUE;

V1:=ABS((2*CLOSE+HIGH+LOW)/4-MA(CLOSE,20))/MA(CLOSE,20);

V2:=(1-7/100)*(DMA(CLOSE,V1));

V3:=(1+7/100)*(DMA(CLOSE,V1));

V5:=MA((LOW+HIGH+CLOSE)/3,5);

支撑:=REFDATE(V2,DATE),DOTLINE,LINETHICK1,COLORLIRED;

阻力:=REFDATE(V3,DATE),DOTLINE,LINETHICK1,COLORGREEN;

DRAWTEXT(ISLASTBAR,阻力,’阻力’),COLORGREEN;

DRAWTEXT(ISLASTBAR,支撑,’支撑’),COLORLIRED;

AAA:=CONST(HHV(H*0.5,90));

AA:=(REF(CLOSE,1)+REF(CLOSE,2)+OPEN)/3;

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.86,0.01,1,’今日保护价’),LINETHICK2,COLOR00FFFF;

DRAWNUMBER_FIX(CURRBARSCOUNT=1,0.90,0.01,1,AA);

DRAWTEXT_FIX(CURRBARSCOUNT=1,0.92,0.01,1,’元’);

PT:=REF(H,1)-REF(L,1);

CDP:=(REF(H,1)+REF(L,1)+REF(C,1)*2)/4;

AH:=CDP+PT;

AL:=CDP-PT;

NH:=CDP*2-REF(L,1);

NL:=CDP*2-REF(H,1);

强:=IF(AH>REF(C,1)*1.1,REF(C,1)*1.1,AH);

阻:=IF(NH>强,(强-CDP)*0.618+CDP,NH);

M:=IF(AL<REF(C,1)/1.1,REF(C,1)/1.1,AL);

撑:=IF(NL<M,CDP-(CDP-M)*0.618,NL);

底:=IF(AL<REF(C,1)/1.1,REF(C,1)/1.1,AL);

今日保护价:=(REF(C,2)+REF(C,1)+O)/3 ;

顶点:IF(CURRBARSCOUNT<=60, CONST(IF(ISLASTBAR=1,HHV(H, BARSLAST(CURRBARSCOUNT=60)),1)),DRAWNULL),COLORYELLOW,DOTLINE;

低点:IF(CURRBARSCOUNT<=60, CONST(IF(ISLASTBAR=1,LLV(L, BARSLAST(CURRBARSCOUNT=60)),1)),DRAWNULL),COLORMAGENTA,DOTLINE;

DRAWTEXT(ISLASTBAR,顶点,’顶点’),COLORYELLOW;

DRAWTEXT(ISLASTBAR,低点,’底点’),COLORMAGENTA;

BS:=1;

MA7:=MA(CLOSE,BS);

转强:=(6*H+5*REF(H,1)+4*REF(H,2)+3*REF(H,3)+2*REF(H,4)+1*REF(H,5))/(6+5+4+3+2+1);

转弱:=(6*L+5*REF(L,1)+4*REF(L,2)+3*REF(L,3)+2*REF(L,4)+1*REF(L,5))/(6+5+4+3+2+1);

BB2:=IF(C>REF(转强,1),1,IF(C<REF(转弱,1),-1,0));

DD2:=BARSLAST(NOT(BB2=0));

B:=IF(BB2=0,REF(BB2,DD2),BB2);

中短:=IF(B=-2,MA(HIGH,6),MA(LOW,6));

STICKLINE(MA7<中短,LOW,HIGH,0,1),COLORCYAN;

STICKLINE(MA7>中短,LOW,HIGH,0,1),COLORRED;

STICKLINE(((OPEN>CLOSE)AND(MA7<中短)),(CLOSE-0.003),OPEN,3.1,0),COLORCYAN;

STICKLINE(((OPEN<CLOSE)AND(MA7<中短)),CLOSE,OPEN,3.1,1),COLORCYAN;

STICKLINE(((OPEN>CLOSE)AND(MA7>中短)),OPEN,(CLOSE-0.003),3.1,0),COLORRED;

STICKLINE(((OPEN<CLOSE)AND(MA7>中短)),OPEN,CLOSE,3.1,1),COLORRED;

B点:=CROSS(MA7,中短);

持股:=MA7>中短;

DRAWICON(CROSS(MA7,中短),L*0.98,7);

DRAWICON(CROSS(中短,MA7),H*1.02,8);

{地区板块行业}

Z1:=STRCAT(HYBLOCK,’ ‘);

Z2:=STRCAT(Z1,DYBLOCK);

Z3:=STRCAT(Z2,’ ‘);

DRAWTEXT_FIX(ISLASTBAR,0.01,0.01,0,STRCAT(Z3,GNBLOCK)),COLORYELLOW;

声明:本站所有文章、数据仅供参考,投资有风险,选择需谨慎

发表评论

登录后才能评论